Subject: Re: test suites for TCP

From: Bob Braden <[email-masked]>
Date: Tue, 13 Nov 2001 16:33:32 GMT

*> From [email-masked]  Tue Nov 13 01:30:31 2001
  *> Date: Tue, 13 Nov 2001 10:12:54 +0100
  *> From: Andi Kleen <[email-masked]>
  *> To: Chetan Kumar <[email-masked]>
  *> Cc: [email-masked]
  *> Subject: Re: test suites for TCP
  *> Mime-Version: 1.0
  *> 
  *> On Tue, Nov 13, 2001 at 06:39:12AM +0100, Chetan Kumar wrote:
  *> > Hi,
  *> > 
  *> > 	I would like to know is there any standard test suites to test TCP
  *> > implementations.
  *> There is unfortunately no standard test suite for TCP. That is one of the
  *> reasons why it is so hard to write a good TCP.
  *> 
  *> -Andi
  *> 

Unnnhhh, the lack of a standard test is the least of an implementor's
problems!!  I wrote my TCP in 1979, and I came away from the experience
with a profound respect for the sublety of the protocol.

Bob Braden

---

From: Charles Esson <[email-masked]>
Date: Fri, 16 Nov 2001 22:46:15 +1100

I wrote mine in 1999 so can remember the experience reasonable well.
TCP/IP may be subtle, RFC793 is a mess. I would have enormous respect
for anyone who could rewrite it a tight manner.

Regards