Subject: RE: test suites for TCP

From: Steve Potuzak <[email-masked]>
Date: Tue, 13 Nov 2001 12:28:02 -0800

Hello,

You might want to look into the ANVL data-network product line from
Empirix..
it consists of a family of automated test suites that attempt to test,
as completely as possible, against relevant RFC's (especially 793).
At least some of the flexibility you mentioned concerning delay or
reordering
may possibly be introduced via their associated TCP development toolkit,
although since I have not attempted it myself, I can't say with certainty.
In any case, we are using the ANVL core TCP/IP test suite here at iReady
Corporation.

The following are related links..

http://www.empirix.com/empirix/voice+network+test/products/data+network+test
.html

http://www.empirix.com/Empirix/default.html

Steven Potuzak
sr. diagnostic software engineer
iReady Corporation
[email-masked]
808.944.5257 x21
1357 Kapiolani Blvd. Suite 102
Honolulu, HI 96814

-----Original Message-----
From: Robin Uyeshiro 
Sent: Tuesday, November 13, 2001 8:41 AM
To: Steve Potuzak
Subject: FW: test suites for TCP

-----Original Message-----
From: Andrei Gurtov [mailto:[email-masked]]
Sent: Monday, November 12, 2001 9:18 PM
To: [email-masked]
Subject: RE: test suites for TCP

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Chetan Kumar
> Sent: 13. marraskuuta 2001 7:39
> To: [email-masked]
> Subject: test suites for TCP
>
>
> Hi,
>
> 	I would like to know is there any standard test suites to test TCP
> implementations.

There is a number of 'fingerprinting' methods to check which TCP
implementation is used, see e.g.
http://www.networkice.com/Advice/Countermeasures/Scanners/Fingerprinting/def
ault.htm

TBIT tool by ACIRI can tell whether a given TCP uses congestion control, the
size of inital window, etc.
http://www.aciri.org/tbit/

However, it would be nice to have a standard test suit for a network
emulator like Dummynet, Nistnet, ONE or Seawind to be able to test different
TCPs by inserting a pattern of drops, delay or reodering into a connection.

Andrei

---

From: Bob Braden <[email-masked]>
Date: Tue, 13 Nov 2001 23:04:41 GMT

You might find RFC 1025 either a useful source or a source of amusement,
depending on your viewpoint.

Bob Braden