Subject: Re: test suites for TCP

From: Bob Braden <[email-masked]>
Date: Fri, 16 Nov 2001 00:33:26 GMT

*> From [email-masked]  Thu Nov 15 16:14:34 2001
  *> Date: Fri, 16 Nov 2001 22:46:15 +1100
  *> From: Charles Esson <[email-masked]>
  *> X-Accept-Language: en
  *> MIME-Version: 1.0
  *> To: Bob Braden <[email-masked]>
  *> CC: [email-masked], [email-masked], [email-masked]
  *> Subject: Re: test suites for TCP
  *> Content-Transfer-Encoding: 7bit
  *> 
  *> I wrote mine in 1999 so can remember the experience reasonable well.
  *> TCP/IP may be subtle, RFC793 is a mess. I would have enormous respect
  *> for anyone who could rewrite it a tight manner.
  *> 
  *> Regards
  *> 

Actually I have profound admiration for RFC 793.  At the time, it was
a remarkable achievement, and I believe that today very, very few
protocol documents achieve the same clarity and elegance.  Of course
it omits many subtleties that were added later -- slow start,
congestion avoidance, large windows, PAWS, SACK, ...

Bob Braden

---

From: Henk Langeveld - NL <[email-masked]>
Date: Fri, 16 Nov 2001 09:54:20 +0100

> congestion avoidance, large windows, PAWS, SACK, ...

A risk of test-suites in any industry is that people may start to
confuse the test-suite with the standard.  No test-suite can ever
be exhaustive.

Internet Standards require interoperability.
This is why interop (and the various bake-offs[?]) was started.  You need
to keep coming back, and keep matching up new implementations of old and
new standards and extensions to them.

Henk Langeveld