Subject: Fw: Query - TCP Window Advertisement.

From: "Udaya kumar" <[email-masked]>
Date: Mon, 10 Dec 2001 14:49:31 +0530

Hi Alan
          Does the explanation below mean that persist timer should be used
in the SYN SENT state.

If the TCP A that sends out a SYN receive a SYN,ACK from the other TCP B
with window advt. as zero then should TCP A probe the window of TCP B.
Anyway connection establishment timer would gain priority and report event
on failure to establish conn. even though persist timer may be working and
hence window probing may not go on until window availability is shown from
TCP B.

Is sending SYN,ACK with zero window advt. valid then???
Can persist timer co-exist with conn. establishment timer????

May be dropping a SYN segment is the only option when resource (memory)  is
not available.

Expecting ur reply.

thanks
uday

> ----- Original Message -----
> From: "Alan Cox" <[email-masked]>
> To: "Srinivas" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, December 07, 2001 3:10 PM
> Subject: Re: Query - TCP Window Advertisement.
>
>
> > > When a TCP at the receiver side receives a SYN packet when it has not
=
> > > got any resource( memory buffer) to support additional connections,
how
> =
> > > should it respond to the incoming SYN packet.
> > > 1) should it send a reset to the other end.
> > > 2) or should it send a SYN,ACK in response with a window advertisement
=
> > > of zero.
> >
> > 3) drop it
> >
> > Seriously - if you have a reasonable expectation you might be able to
> handle
> > it next time around, throw the frame away. The client will politely
retry
> > and do back off until resource exists or the user gets bored.
> >
> > If you want to implement some kind of queueing then syn|ack with window
> zero
> > is also perfectly reasonable, and will let you hold the connection and
> then
> > process it in order.
> >
> > Sending a reset seems to be wrong in just about all cases. Its not that
> > nobody is listening on the port (which RST would be saying) its "give me
a
> > minute I'll get around to you"
> >
> > Alan
>

---

From: Alan Cox <[email-masked]>
Date: Mon, 10 Dec 2001 09:55:56 +0000 (GMT)

> Can persist timer co-exist with conn. establishment timer????

I don't see why the question arises.  You can send an ack into a zero window

---

From: [email-masked]
Date: Mon, 10 Dec 2001 19:46:24 +0300 (MSK)

Hello!

> I don't see why the question arises.  You can send an ack into a zero window

Seems, he thinks some other timer ("conn. establishment timer")
exists in this state. It does not exist, the state is normal good ESTABLISHED
after receiving SYN,ACK. No special timers is running and window may be
of any value, of course.

Alexey