Subject: Doubt regarding PUSH bit, req.

From: "Srinivas Amaravadi" <[email-masked]>
Date: Fri, 14 Dec 2001 21:42:11 +0530

Hi all,

Here comes a small doubt about the PUSH bit.
can TCP Stack set the PUSH bit by its own. i.e, Eventhough the Application sitting over the TCP Stack gives the send call  WITHOUT psh bit, can the stack set the psh bit and send the segment out?? if so then on what conditions the stack sets the psh bit on the segment ??

Regards
srinivas

---

From: [email-masked]
Date: Fri, 14 Dec 2001 10:33:52 -0600 (CST)

> From: "Srinivas Amaravadi" <[email-masked]>
> To: <[email-masked]>
> Subject: Doubt regarding PUSH bit,  req.
> Date: Fri, 14 Dec 2001 21:42:11 +0530
...
> can TCP Stack set the PUSH bit by its own. i.e, Eventhough the
> Application sitting over the TCP Stack gives the send call  WITHOUT psh
> bit, can the stack set the psh bit and send the segment out?? if so then

Yes.

> on what conditions the stack sets the psh bit on the segment ??

The BSD TCP code sets the PUSH bit in any packet when there
is no additional data waiting to be sent.

		-David Borman, [email-masked]