Subject: Re: [webfinger] [apps-discuss] WebFinger payload as array or object

From: ☮ elf Pavlik ☮ <[email-masked]>
Date: Tue, 11 Dec 2012 20:40:18 +0000

Excerpts from Markus Lanthaler's message of 2012-11-30 13:16:32 +0000:
> On Friday, November 30, 2012 12:50 PM, ☮ elf Pavlik ☮
> >
> > [just brainstorming] would you see sense in evaluating use of JSON-LD ?
> > :)
> 
> That depends on what you mean by evaluating use of JSON-LD!?
> 
> If you mean exposing "generic" JSON-LD, i.e., JSON-LD without any restrictions on the shape of the data (JSON-LD serializes graphs and most of the time there are multiple ways to transform a graph to a tree) I don't think it would make much sense.
> 
> However, if you mean to ensure that a webfinger response can be transfomred to a JSON-LD document I think it would make a lot of sense. Especially considering how trivial the "required" changes are. Actually those changes are not required in the traditional sense but are required to extract data that is easy to consume. The current structure would yield to data whose structure is quite unusual and difficult to consume. 
> 
> After a quick glance it looks like that moving the rels out of the link objects would be all that's required. If you want to push this a bit further you could rename href to subject as those objects than basically again represent subjects. Perhaps you would even like to go as far as removing the "properties" and "links" keys and put that data directly in the top-level object. After all, both are properties of the subject.
thank you for clarifying!

also just recalled JSON-LD Macros project which could maybe help with providing common transformations for webfinger profiles to JSON-LD: https://github.com/antoniogarrote/json-ld-macros

---

From: "Markus Lanthaler" <[email-masked]>
Date: Thu, 13 Dec 2012 22:57:47 +0100

On Tuesday, December 11, 2012 9:40 PM, ☮ elf Pavlik ☮ wrote:
> also just recalled JSON-LD Macros project which could maybe help with
> providing common transformations for webfinger profiles to JSON-LD:
> https://github.com/antoniogarrote/json-ld-macros

Right. Of course you could always use some simple pre-processing steps to transform it to sensible JSON-LD.

--
Markus Lanthaler
@markuslanthaler